[PATCH] D82373: [CodeComplete] Tweak code completion for `typename`
Kadir Cetinkaya via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Tue Jun 23 13:59:24 PDT 2020
kadircet accepted this revision.
kadircet added a comment.
This revision is now accepted and ready to land.
LGTM, as previous version only saves a single character, i.e. pressing a single tab after qualifier vs hitting `:` twice, while it is annoying for the non-qualified case, now you need to delete the rest.
let me know if I should land this for you.
================
Comment at: clang/lib/Sema/SemaCodeComplete.cpp:1693
Builder.AddChunk(CodeCompletionString::CK_HorizontalSpace);
- Builder.AddPlaceholderChunk("qualifier");
- Builder.AddTextChunk("::");
- Builder.AddPlaceholderChunk("name");
+ Builder.AddPlaceholderChunk("identifier");
Results.AddResult(Result(Builder.TakeString()));
----------------
nit: let's use `name` instead of `identifier`
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D82373/new/
https://reviews.llvm.org/D82373
More information about the cfe-commits
mailing list