[PATCH] D80222: Replace Clang's createRuntimeFunction with the definitions in OMPKinds.def
Johannes Doerfert via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Wed May 20 16:00:59 PDT 2020
jdoerfert added a comment.
We pass all clang tests, right?
================
Comment at: llvm/include/llvm/Frontend/OpenMP/OMPIRBuilder.h:203
+ static Function *getOrCreateRuntimeFunction(Module &Md,
+ omp::RuntimeFunction FnID);
----------------
Nit: M is the commonly used name for a module ;)
================
Comment at: llvm/include/llvm/Frontend/OpenMP/OMPKinds.def:370
__OMP_RTL(__kmpc_critical_with_hint, false, Void, IdentPtr, Int32,
- KmpCriticalNamePtrTy, Int32)
+ KmpCriticalNamePtrTy, /* int32? */ Int32)
__OMP_RTL(__kmpc_end_critical, false, Void, IdentPtr, Int32,
----------------
What about the comments with a `?`?
================
Comment at: llvm/lib/Frontend/OpenMP/OMPIRBuilder.cpp:83
IsVarArg), \
- GlobalValue::ExternalLinkage, Str, M); \
+ GlobalValue::ExternalLinkage, Str, Md); \
break;
----------------
`M`
================
Comment at: llvm/lib/Frontend/OpenMP/OMPIRBuilder.cpp:103
+ }
+ } else if (Fn->getName() == "__kmpc_fork_teams") {
+ if (!Fn->hasMetadata(LLVMContext::MD_callback)) {
----------------
Please use `FnID` for the comparison.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D80222/new/
https://reviews.llvm.org/D80222
More information about the cfe-commits
mailing list