[PATCH] D77594: [SveEmitter] Add support for _n form builtins

Sander de Smalen via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Wed Apr 22 07:00:59 PDT 2020


sdesmalen marked an inline comment as done.
sdesmalen added inline comments.


================
Comment at: clang/utils/TableGen/SveEmitter.cpp:212
+  bool hasSplat() const {
+    return Proto.find_first_of("ajfrKLR") != std::string::npos;
+  }
----------------
SjoerdMeijer wrote:
> "ajfrKLR" -> bingo ;-)
> 
> This probably makes sense, but who knows :-)
> Not even sure if a comment makes things better here...
> "ajfrKLR" -> bingo ;-)

Haha! You are right these prototype modifiers are not very readable. The arm_sve.td file describes the prototype modifiers at the top though, and I've added a comment suggesting where to find it.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D77594/new/

https://reviews.llvm.org/D77594





More information about the cfe-commits mailing list