[PATCH] D77802: [analyzer] Improved RangeSet::Negate support of unsigned ranges
Denys Petrov via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Wed Apr 22 03:44:56 PDT 2020
ASDenysPetrov marked an inline comment as done.
ASDenysPetrov added inline comments.
================
Comment at: clang/lib/StaticAnalyzer/Core/RangeConstraintManager.cpp:217
+
+ const llvm::APSInt sampleValue = getMinValue();
+ const bool isUnsigned = sampleValue.isUnsigned();
----------------
ASDenysPetrov wrote:
> steakhal wrote:
> > Should we take it as `const ref` to prevent copying?
> getMinValue returns APSInt by value, so it wouldn't make sense.
My fault. Yes, you are right. I've missed &. I used to append & to the type, since it is more readable and actually is a part of type, but I won't debate with clang style guide :).
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D77802/new/
https://reviews.llvm.org/D77802
More information about the cfe-commits
mailing list