[PATCH] D77233: [NFC] Refactoring PropertyAttributeKind for ObjCPropertyDecl and ObjCDeclSpec.
Erik Pilkington via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Tue Apr 14 06:22:52 PDT 2020
erik.pilkington added inline comments.
================
Comment at: clang/include/clang-c/Index.h:4503
CXObjCPropertyAttr_unsafe_unretained = 0x800,
- CXObjCPropertyAttr_class = 0x1000
+ CXObjCPropertyAttr_classattr = 0x1000
} CXObjCPropertyAttrKind;
----------------
plotfi wrote:
> erik.pilkington wrote:
> > plotfi wrote:
> > > @erik.pilkington Do you think we should be adding the C-API analogs of nullability / null_resettable (and direct) to clang/include/clang-c/Index.h?
> > >
> > > I noticed those are missing.
> > >
> > >
> > Oh, sorry, I missed this. The C API is supposed to be stable, so I don't think we should change the name of this enumerator (@arphaman can you confirm?). Adding the missing attributes seem fine though.
> @erik.pilkington @arphaman Any chance I can land the C API changes in a follow up commit? That's what I was thinking.
I think this enumerator should stay named `CXObjCPropertyAttr_class`, changing the name to `CXObjCPropertyAttr_classattr` is API breaking, and the C API should be stable.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D77233/new/
https://reviews.llvm.org/D77233
More information about the cfe-commits
mailing list