[PATCH] D74813: [RFC] Add hash of block contents to function block names
Erik Pilkington via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Wed Apr 8 13:35:38 PDT 2020
erik.pilkington added a comment.
What do you think about using the block type instead of a hash? That should be stable across compiler versions, changes to the block body, and changes to referenced declarations. You'd still have to number blocks of the same type within the same function, but that should be a much smaller problem. It'd also allow demanglers to provide more information about the symbol, e.g. a demangler could print:
`block invocation function for block of type void (^)(int) in main`
As opposed to what it prints today, which doesn't really tell you much about which block you're looking at:
`block invocation function for block in main`.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D74813/new/
https://reviews.llvm.org/D74813
More information about the cfe-commits
mailing list