[PATCH] D75661: Remove SequentialType from the type heirarchy.
Christopher Tetreault via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Wed Mar 18 11:25:01 PDT 2020
ctetreau added a comment.
> I'm concerned though about having getSequentialElementType and getSequentialNumElements apply to different sets of types. That's bound to lead to confusion which causes bugs. Can we have one name for all types that are homogenous sequences of the same element type, and a different name for all types which are *fixed-length* homogenous sequences?
isSequentialType() returns true for VectorType and ArrayType. It should be changed to only return true if the vector type is not scalable, and getSequentialNumElements() should assert isSequentialType() before attempting the casts.
In the future, when my proposed FixedVectorType is added, isSequentialType will return true for ArrayType and FixedVectorType only.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D75661/new/
https://reviews.llvm.org/D75661
More information about the cfe-commits
mailing list