[PATCH] D74620: [ARM,MVE] Add vector-scalar intrinsics

Dave Green via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Mon Feb 17 09:17:58 PST 2020


dmgreen accepted this revision.
dmgreen added a comment.
This revision is now accepted and ready to land.

LGTM.



================
Comment at: llvm/lib/Target/ARM/ARMInstrMVE.td:4566
+                          0b0, VTI.Unsigned>;
+  defvar unpred_op = !if(VTI.Unsigned, unpred_op_u, unpred_op_s);
+  defm : MVE_vec_scalar_int_pat_m<!cast<Instruction>(NAME), VTI,
----------------
dmgreen wrote:
> I find all these if's at different levels a little hard to follow. It looks OK, but is it possible to rearrange things to not need it here?
I meant trying to remove this `defvar unpred_op = !if(` line. I think it's always going to be a bit difficult to follow whatever we do here though (or we end up repeating ourselves a lot), so you can ignore this one :)


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D74620/new/

https://reviews.llvm.org/D74620





More information about the cfe-commits mailing list