[PATCH] D73346: [clangd] Rename DiagnosticsConsumer -> ClangdServer::Callbacks, and make it optional

Haojian Wu via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Fri Jan 24 05:46:41 PST 2020


hokein accepted this revision.
hokein added inline comments.
This revision is now accepted and ready to land.


================
Comment at: clang-tools-extra/clangd/ClangdServer.h:76
+    /// May be called concurrently for separate files, not for a single file.
+    virtual void onFileUpdated(PathRef File, const TUStatus &Status){};
+
----------------
nit : clang-format.


================
Comment at: clang-tools-extra/clangd/ClangdServer.h:166
   /// After each parsing request finishes, ClangdServer reports diagnostics to
   /// \p DiagConsumer. Note that a callback to \p DiagConsumer happens on a
   /// worker thread. Therefore, instances of \p DiagConsumer must properly
----------------
nit: the doc is out-of-date now.


================
Comment at: clang-tools-extra/clangd/unittests/ClangdTests.cpp:277
   } FS;
-  struct DiagConsumer : public DiagnosticsConsumer {
+  struct DiagConsumer : public ClangdServer::Callbacks {
     void onDiagnosticsReady(PathRef File,
----------------
nit: maybe rename this class as well.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D73346/new/

https://reviews.llvm.org/D73346





More information about the cfe-commits mailing list