[PATCH] D72427: [DebugInfo] Add option to clang to limit debug info that is emitted for classes.

Amy Huang via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Fri Jan 10 12:05:54 PST 2020


akhuang updated this revision to Diff 237411.
akhuang added a comment.

Address comments

- Removed driver option
- Simplified test cases
- Changed name of limited debug info from isFullDebug to hasReducedDebugInfo, which is maybe

slightly less misleading


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D72427/new/

https://reviews.llvm.org/D72427

Files:
  clang/include/clang/Basic/CodeGenOptions.h
  clang/include/clang/Basic/DebugInfoOptions.h
  clang/lib/CodeGen/CGBlocks.cpp
  clang/lib/CodeGen/CGDebugInfo.cpp
  clang/lib/CodeGen/CGDecl.cpp
  clang/lib/CodeGen/CGStmt.cpp
  clang/lib/CodeGen/CGStmtOpenMP.cpp
  clang/lib/CodeGen/CodeGenFunction.cpp
  clang/lib/CodeGen/CodeGenModule.cpp
  clang/lib/Driver/ToolChains/Clang.cpp
  clang/lib/Frontend/CompilerInvocation.cpp
  clang/test/CodeGenCXX/debug-info-limited-ctor.cpp

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D72427.237411.patch
Type: text/x-patch
Size: 17436 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20200110/8ea57912/attachment-0001.bin>


More information about the cfe-commits mailing list