[PATCH] D72284: [clang-tidy] Factor out renaming logic from readability-identifier-naming
Logan Smith via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Mon Jan 6 16:34:06 PST 2020
logan-5 added inline comments.
================
Comment at: clang-tools-extra/clang-tidy/utils/RenamerClangTidyCheck.cpp:272
+ if (const auto *Typedef =
+ Value->getReturnType().getTypePtr()->getAs<TypedefType>()) {
+ addUsage(NamingCheckFailures, Typedef->getDecl(),
----------------
Eugene.Zelenko wrote:
> Please elide braces.
Would you mind pointing me toward a resource for these formatting nits? I don't see anything about requiring omitting braces for single-statement if()s in the official LLVM coding standards (and I happen to think the braces actually help readability here). If this stuff is explicitly documented somewhere and painstakingly enforced like this, I'd rather get it right the first time.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D72284/new/
https://reviews.llvm.org/D72284
More information about the cfe-commits
mailing list