[PATCH] D72121: [clang-tidy] Fix readability-identifier-naming missing member variables

Aaron Ballman via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Mon Jan 6 11:45:58 PST 2020


aaron.ballman added inline comments.


================
Comment at: clang-tools-extra/test/clang-tidy/checkers/readability-identifier-naming-member-decl-usage.cpp:137
+}
+}; // namespace CtorInits
----------------
I think this is one more test case to add: base class specifiers. e.g.,
```
struct foo_bar {}; // Should be renamed

struct Baz : foo_bar {}; // Should rename foo_bar
```


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D72121/new/

https://reviews.llvm.org/D72121





More information about the cfe-commits mailing list