[PATCH] D71018: [ASTImporter] Improved import of TypeSourceInfo (TypeLoc)

Balázs Kéri via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Wed Dec 4 08:27:20 PST 2019


balazske added inline comments.


================
Comment at: clang/lib/AST/ASTImporter.cpp:7914
+
+#define IMPORT(NAME)                                                           \
+  if (auto ImpOrErr = Importer.Import(From.get##NAME()))                       \
----------------
I think this should have a less-generic name for example `TypeLocImporter_IMPORT`.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D71018/new/

https://reviews.llvm.org/D71018





More information about the cfe-commits mailing list