[PATCH] D70583: clang/Modules: Rename CompilerInstance::ModuleManager, NFC
Duncan P. N. Exon Smith via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Thu Nov 21 18:45:10 PST 2019
dexonsmith created this revision.
dexonsmith added reviewers: Bigcheese, jkorous, rsmith, bruno.
Herald added subscribers: ributzka, kbarton, nemanjai.
dexonsmith added a parent revision: D70556: clang/Modules: Refactor CompilerInstance::loadModule, NFC.
Herald added a subscriber: wuzish.
Fix the confusing naming of `CompilerInstance::ModuleManager`. This is
actually an instance of `ASTReader`, which contains an instance of
`ModuleManager`. I have to assume there was a point in the past where
they were just one class, but it's been pretty confusing for a while. I
think it's time to fix it.
The new name is `TheASTReader`; the annoying `The` prefix is so that we
don't shadow the `ASTReader` class. I tried out `ASTRdr` but that
seemed less clear, and this choice matches `ThePCHContainerOperations`
just a couple of declarations below.
Also rename `CompilerInstance::getModuleManager` and
`CompilerInstance::createModuleManager` to `*ASTReader`, making some
cases of `getModuleManager().getModuleManager()` a little more clear.
I built this on top of https://reviews.llvm.org/D70556 so I don't need to do an annoying rebase later.
https://reviews.llvm.org/D70583
Files:
clang-tools-extra/clang-tidy/ExpandModularHeadersPPCallbacks.cpp
clang/include/clang/Frontend/CompilerInstance.h
clang/lib/Frontend/ASTUnit.cpp
clang/lib/Frontend/CompilerInstance.cpp
clang/lib/Frontend/FrontendAction.cpp
clang/lib/Frontend/Rewrite/FrontendActions.cpp
clang/lib/Tooling/DependencyScanning/ModuleDepCollector.cpp
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D70583.230578.patch
Type: text/x-patch
Size: 14950 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20191122/a08b3cc6/attachment-0001.bin>
More information about the cfe-commits
mailing list