[PATCH] D69356: [NFC] Rename LLVM_NO_DEAD_STRIP

Chris Bieneman via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Wed Oct 30 10:22:21 PDT 2019


beanz added a comment.

In D69356#1726527 <https://reviews.llvm.org/D69356#1726527>, @hubert.reinterpretcast wrote:

> For your second question: As the patch author indicated, the change to adjust the behaviour on the affected platform is forthcoming. Your question seems predicated upon that not happening.


I'm actually opposed to that happening, on two fronts.
(1) dead stripping support is useful independent of plugins, so it is valuable to have that option be separate
(2) we already have `LLVM_ENABLE_PLUGINS` why do we also need `LLVM_SUPPORT_PLUGINS` seems like duplication and bad design.

> Just because the current implementation of plug-in support is by disabling dead strip does not make it a great reason for "enabling plug-in support" to be called `LLVM_NO_DEAD_STRIP`.

`LLVM_NO_DEAD_STRIP` isn't the implementation of enabling plugin support.

> Maybe `LLVM_EXPORT_SYMBOLS_FROM_EXEC` is a better name?

Not really because exporting symbols and dead stripping aren't actually the same thing. You can dead strip unused symbols *and* export everything else.

I think this change needs to be rolled back, and future changes to the build system should include reviewers with experience maintaining the build system.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D69356/new/

https://reviews.llvm.org/D69356





More information about the cfe-commits mailing list