[PATCH] D67216: [cfi] Add flag to always generate call frame information

David Candler via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Fri Sep 6 08:12:53 PDT 2019


dcandler added a comment.
Herald added a subscriber: ychen.

I was actually torn myself on whether to put the flag in the g group or not, so I'm happy to rename it. As far as I could find, no compiler has an existing option to control this: instead armcc always includes a debug_frame section by default to follow Arm's Dwarf specification. Having it as an option seems more flexible than forcing a different behavior.



================
Comment at: clang/lib/Frontend/CompilerInvocation.cpp:956
                                          OPT_fno_unique_section_names, true);
+  Opts.AlwaysNeedCFI =
+      Args.hasFlag(OPT_falways_need_cfi, OPT_fno_always_need_cfi, false);
----------------
ostannard wrote:
> Is this option actually being read anywhere?
Not any more, since I moved the option directly into AsmPrinter. I'll make sure this (and the other line) doesn't get included in the next diff.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D67216/new/

https://reviews.llvm.org/D67216





More information about the cfe-commits mailing list