[PATCH] D65919: [clang-tidy] Add llvm-prefer-register-over-unsigned check and apply it to LLVM
Daniel Sanders via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Tue Aug 13 16:53:33 PDT 2019
dsanders marked an inline comment as done.
dsanders added inline comments.
================
Comment at: clang-tools-extra/clang-tidy/llvm/LLVMTidyModule.cpp:26
void addCheckFactories(ClangTidyCheckFactories &CheckFactories) override {
+ using readability::NamespaceCommentCheck;
+
----------------
aaron.ballman wrote:
> I would rather use the fully-qualified names below -- the namespaces are actually of interest when needing to see what checks rely on what other modules quickly.
In that case I think I need some more detail on the alphabetical order I need to preserve. Do the namespaces factor into the order? If so, then PreferIsaOrDynCastInConditionalsCheck was in the wrong place prior to this patch and add_new_check.py is behaving correctly. If not, then the existing order was correct but add_new_check.py is inserting new lines incorrectly
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D65919/new/
https://reviews.llvm.org/D65919
More information about the cfe-commits
mailing list