[PATCH] D64481: [clangd] Add a flag to clangdServer rename function to control whether we want format the replacements.
Ilya Biryukov via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Wed Jul 10 06:22:16 PDT 2019
ilya-biryukov accepted this revision.
ilya-biryukov added a comment.
This revision is now accepted and ready to land.
LGTM with a small NIT.
Was also thinking about adding a test for this, but the amount of work required to do so seems to outweigh the usefulness. Therefore seems ok to land without the test too.
But up to you.
================
Comment at: clang-tools-extra/clangd/ClangdServer.h:244
void rename(PathRef File, Position Pos, llvm::StringRef NewName,
- Callback<std::vector<TextEdit>> CB);
+ bool WantFormat, Callback<std::vector<TextEdit>> CB);
----------------
Could you add a short comment mentioning the highlight use-case? (the review description seems to be a good fit)
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D64481/new/
https://reviews.llvm.org/D64481
More information about the cfe-commits
mailing list