[PATCH] D62730: [RFC] Alternate implementation of D53157 IRBuilder for Constrained FP using enumeration vs MDNode and add support for fp-model and fp-speculation language options
Kevin P. Neal via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Fri May 31 08:15:49 PDT 2019
kpn added inline comments.
================
Comment at: include/llvm/IR/FPState.h:9-31
+ enum FPModelKind {
+ FPM_Off,
+ FPM_Precise,
+ FPM_Strict,
+ FPM_Fast
+ };
+
----------------
lebedev.ri wrote:
> All this needs comments, and possibly better names.
> `FPM_Off`,etc is very non-self-explanatory.
Shouldn't there be an "accept default" value? That way CreateConstrainedFAdd()/CreateConstrainedBinOp() can accept enumerations and avoid having front ends having to deal with MDNode*.
Repository:
rL LLVM
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D62730/new/
https://reviews.llvm.org/D62730
More information about the cfe-commits
mailing list