[PATCH] D59347: [DebugInfo] Combine Trivial and NonTrivial flags

David Blaikie via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Wed Mar 27 10:50:02 PDT 2019


dblaikie added a comment.

In D59347#1443051 <https://reviews.llvm.org/D59347#1443051>, @dblaikie wrote:

> @asmith: Where's the LLVM-side change/review that goes with this, btw?
>
> In D59347#1442970 <https://reviews.llvm.org/D59347#1442970>, @probinson wrote:
>
> > As a rule I would prefer flags with positive names, as it's slightly easier to read `!isTrivial` than `!isNonTrivial`. And trivially shorter. :-)
>
>
> Fair enough - I was mostly coming at this from the "the patch that was committed should be reverted" & then we could haggle over other things, but fair point.


Hmm, one other thought: Technically "non trivial" is perhaps more accurate/less error prone. Only marking structures as "trivial" but other types without that marker makes it more subtle (since not all trivial types would be marked trivial - only those of a classification that means they /could/ be non-trivial). Whereas marking the non-trivial types is more broadly accurate.

@asmith - is this patch now essentially a revert of the trivial flag addition? Or are there any parts that were not reverted, if so, why not? (I would expect/imagine all the testing could be reverted too - since the NonTrivial flag was presumably already tested appropriately?)


Repository:
  rC Clang

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D59347/new/

https://reviews.llvm.org/D59347





More information about the cfe-commits mailing list