[PATCH] D57914: [Driver] Allow enum SanitizerOrdinal to represent more than 64 different sanitizer checks, NFC.
Bruno Ricci via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Mon Feb 25 06:12:20 PST 2019
riccibruno added a comment.
It looks better now as far as I can see. I like the idea of aliasing `SanitizerKind` to `SanitizerMasks<>;`.
================
Comment at: include/clang/Basic/Sanitizers.h:133
// bit positions.
enum SanitizerOrdinal : uint64_t {
#define SANITIZER(NAME, ID) SO_##ID,
----------------
`SanitizerOrdinal` used to be in `SanitizerKind`. Would it make sense to keep this by moving it to `SanitizerMasks` ?
================
Comment at: include/clang/Basic/Sanitizers.h:169
-} // namespace SanitizerKind
+// Force instantiate here to ensure correct initialization order.
+template struct SanitizerMasks<>;
----------------
"Force instantiate here [...]" -> "Explicit instantiation here [...]" ?
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D57914/new/
https://reviews.llvm.org/D57914
More information about the cfe-commits
mailing list