[PATCH] D57966: [clang-tidy] add camelBackOrCase casing style to readability-identifier-naming to support change to variable naming policy (if adopted)
MyDeveloperDay via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Fri Feb 8 11:31:28 PST 2019
MyDeveloperDay created this revision.
MyDeveloperDay added reviewers: michaelplatings, aaron.ballman, JonasToth, hokein.
MyDeveloperDay added a project: clang-tools-extra.
Herald added a subscriber: xazax.hun.
Herald added a project: clang.
Introduction of a new variable policy (as outlined in D57896: Variable names rule <https://reviews.llvm.org/D57896>) could lead to clang tidy complaining about 1000's of variables
Consider add a new casing style to `readability-identifier-naming` to support allowing either `camelBack` and `camelCase` styles which could be applied to the VariableCase option in the LLVM .clang-tidy files
Users wishing to convert their files to new policy would simply change this setting to `camelBack` and run with -fix
Depends on D57896 <https://reviews.llvm.org/D57896>
Repository:
rCTE Clang Tools Extra
https://reviews.llvm.org/D57966
Files:
clang-tidy/readability/IdentifierNamingCheck.cpp
clang-tidy/readability/IdentifierNamingCheck.h
docs/ReleaseNotes.rst
docs/clang-tidy/checks/readability-identifier-naming.rst
test/clang-tidy/readability-identifier-naming-camelback-or-case.cpp
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D57966.185998.patch
Type: text/x-patch
Size: 12612 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20190208/0d050191/attachment-0001.bin>
More information about the cfe-commits
mailing list