[PATCH] D45702: [clang-tidy] Add a new check, readability-redundant-data-call, that finds and removes redundant calls to .data().

Eugene Zelenko via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Thu Apr 19 18:30:04 PDT 2018


Eugene.Zelenko added inline comments.


================
Comment at: clang-tidy/readability/RedundantDataCallCheck.cpp:22
+
+const char kDefaultTypes[] =
+    "::std::basic_string;::std::basic_string_view;::std::vector;::std::array";
----------------
shuaiwang wrote:
> Eugene.Zelenko wrote:
> > Actually you should use static, not anonymous namespace for variables and functions.
> Done, but why?
See [[ https://llvm.org/docs/CodingStandards.html#anonymous-namespaces | LLVM coding standards ]].


Repository:
  rCTE Clang Tools Extra

https://reviews.llvm.org/D45702





More information about the cfe-commits mailing list