[PATCH] D45702: [clang-tidy] Add a new check, readability-redundant-data-call, that finds and removes redundant calls to .data().
Shuai Wang via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Thu Apr 19 18:19:48 PDT 2018
shuaiwang added inline comments.
================
Comment at: clang-tidy/readability/RedundantDataCallCheck.cpp:22
+
+const char kDefaultTypes[] =
+ "::std::basic_string;::std::basic_string_view;::std::vector;::std::array";
----------------
Eugene.Zelenko wrote:
> Actually you should use static, not anonymous namespace for variables and functions.
Done, but why?
Repository:
rCTE Clang Tools Extra
https://reviews.llvm.org/D45702
More information about the cfe-commits
mailing list