r206491 - Nitpicky refactoring -- use of nullptr and auto, made a bit more const-correct. No functional changes intended.
Richard Smith
richard at metafoo.co.uk
Fri Apr 18 01:39:44 PDT 2014
On 18 Apr 2014 00:37, "Daniel Marjamäki" <Daniel.Marjamaki at evidente.se>
wrote:
>
>
> Hello!
>
> > - if (AvailabilityAttr *AA = dyn_cast<AvailabilityAttr>(Attr))
> > + if (const auto *AA = dyn_cast<AvailabilityAttr>(Attr))
>
> Personally I don't think hiding "AvailabilityAttr" with "auto" makes the
code much more readable here. In my humble opinion the auto should only be
used if it really makes the code easier to read.
>From the llvm coding standard:
" use auto with initializers like cast<Foo>(...) or other places where the
type is already obvious from the context. "
> Best regards,
> Daniel Marjamäki
>
>
..................................................................................................................
> Daniel Marjamäki Senior Engineer
> Evidente ES East AB Warfvinges väg 34 SE-112 51 Stockholm Sweden
>
> Mobile: +46 (0)709 12 42 62
> E-mail: Daniel.Marjamaki at evidente.se
>
> www.evidente.se
>
> _______________________________________________
> cfe-commits mailing list
> cfe-commits at cs.uiuc.edu
> http://lists.cs.uiuc.edu/mailman/listinfo/cfe-commits
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20140418/7888a0c7/attachment.html>
More information about the cfe-commits
mailing list