r206491 - Nitpicky refactoring -- use of nullptr and auto, made a bit more const-correct. No functional changes intended.
Daniel Marjamäki
Daniel.Marjamaki at evidente.se
Fri Apr 18 00:36:00 PDT 2014
Hello!
> - if (AvailabilityAttr *AA = dyn_cast<AvailabilityAttr>(Attr))
> + if (const auto *AA = dyn_cast<AvailabilityAttr>(Attr))
Personally I don't think hiding "AvailabilityAttr" with "auto" makes the code much more readable here. In my humble opinion the auto should only be used if it really makes the code easier to read.
Best regards,
Daniel Marjamäki
..................................................................................................................
Daniel Marjamäki Senior Engineer
Evidente ES East AB Warfvinges väg 34 SE-112 51 Stockholm Sweden
Mobile: +46 (0)709 12 42 62
E-mail: Daniel.Marjamaki at evidente.se
www.evidente.se
More information about the cfe-commits
mailing list