[PATCH] InstrProf: Calculate a better function hash

Duncan P. N. Exon Smith dexonsmith at apple.com
Thu Apr 10 16:46:31 PDT 2014


On Apr 10, 2014, at 3:56, Chandler Carruth <chandlerc at google.com> wrote:

> Another set of diffs that really should be pulled out into a separate commit:
> 
>      /// Assign a counter to track entry to the function body.
> -    void VisitFunctionDecl(const FunctionDecl *S) {
> -      CounterMap[S->getBody()] = NextCounter++;
> -      Visit(S->getBody());
> +    void VisitFunctionDecl(const FunctionDecl *D) {
> +      assignCounter(D);
> +      Visit(D->getBody());
>      }
> 
> All of the simple parameter renames are fine, just commit those. No need to clutter up the functional change.
> 

r206002



More information about the cfe-commits mailing list