[cfe-commits] PATCH: Make OBJC_AT_KEYWORD_NAME more Doxygen- (and human-) friendly.

James Dennett jdennett at google.com
Wed Jun 13 19:58:04 PDT 2012


This makes SemaCodeComplete.cpp more Doxygen-friendly by changing the
OBJC_AT_KEYWORD_NAME take a string literal argument where previously
its second argument was an unquoted token; macro invocations such as
OBJC_AT_KEYWORD_NAME(NeedAt,{) confuse Doxygen's parser.

While I'm wary of changing code (rather than just comments) to work
around Doxygen's limitations, in this case the change makes the code
more readable for human beings as well, and the macro derived no
benefit from using the preprocessor's stringification operator, as
it never has need of the unquoted token.

I've also included a couple of trivial drive-by fixes to doc comments.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: at-macro.patch
Type: application/octet-stream
Size: 10025 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20120613/dd0dc91c/attachment.obj>


More information about the cfe-commits mailing list