[cfe-commits] [PATCH] Multiple patches for refactoring SemaExpr.cpp

Richard Trieu rtrieu at google.com
Tue Aug 9 15:30:08 PDT 2011


On Mon, Aug 8, 2011 at 6:39 PM, Richard Trieu <rtrieu at google.com> wrote:

> Refactoring of lib/Sema/SemaExpr.cpp broken into several patches.  Changes
> include reducing code duplication, moving diagnostic checks into separate
> functions, and reducing method length.  Comments welcome.


Uploaded to Rietveld.

Change to DiagnoseBitwisePrecedence()
http://codereview.appspot.com/4830067/

Refactor CheckAddressOfOperand()
http://codereview.appspot.com/4856050/

Consolidate shared code between Check (Addition, Subtract,
IncrementDecrement) Operands()
http://codereview.appspot.com/4832063/

Reduce duplicate code in pointer comparisons
http://codereview.appspot.com/4856049/

Refactor UsualArithmeticConversions()
http://codereview.appspot.com/4810092/

Refactor CheckConditionalOperands()
http://codereview.appspot.com/4859041/

Move incomplete type in pointer arithmetic to new function
http://codereview.appspot.com/4841059/

Move null arithmetic check and different enum check to new functions
http://codereview.appspot.com/4810091/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20110809/63ac344d/attachment.html>


More information about the cfe-commits mailing list