[all-commits] [llvm/llvm-project] 1c85c7: [mlir][vector] Refactor vector-transfer-flatten.ml...

Andrzej Warzyński via All-commits all-commits at lists.llvm.org
Fri Jun 21 04:48:48 PDT 2024


  Branch: refs/heads/main
  Home:   https://github.com/llvm/llvm-project
  Commit: 1c85c711aadb65943f5187524274fc96d1151b02
      https://github.com/llvm/llvm-project/commit/1c85c711aadb65943f5187524274fc96d1151b02
  Author: Andrzej Warzyński <andrzej.warzynski at arm.com>
  Date:   2024-06-21 (Fri, 21 Jun 2024)

  Changed paths:
    M mlir/test/Dialect/Vector/vector-transfer-flatten.mlir

  Log Message:
  -----------
  [mlir][vector] Refactor vector-transfer-flatten.mlir (nfc) (2/n) (#95744)

The main goal of this and subsequent PRs is to unify and categorize
tests in:
  * vector-transfer-flatten.mlir
  
This should make it easier to identify the edge cases being tested (and
how they differ), remove duplicates and to add tests for scalable
vectors.

Below are the main contributions of this PR

1. Two tests duplicated
  `@transfer_{read|write}_dims_mismatch_non_contiguous_slice`:
    * `@transfer_{read|write}_dims_mismatch_non_contiguous` and
    * `@transfer_read_flattenable_negative` duplicated
  `@transfer_{read|write}_dims_mismatch_non_contiguous_slice`.
  
   These tests are removed (the original test is preserved).

2. `@transfer_read_flattenable_negative2` is replaced with
   two tests with more descriptive names:
    * `@transfer_read_non_contiguous_src` (for `xfer_read`) and
    * `@transfer_write_non_contiguous_src` (for `xfer_write`)



To unsubscribe from these emails, change your notification settings at https://github.com/llvm/llvm-project/settings/notifications


More information about the All-commits mailing list