[all-commits] [llvm/llvm-project] 65b123: [BPF] rename 'arena' to 'address_space' (#85161)
eddyz87 via All-commits
all-commits at lists.llvm.org
Thu Mar 14 19:20:28 PDT 2024
Branch: refs/heads/main
Home: https://github.com/llvm/llvm-project
Commit: 65b123e287d1320170bb3317179bc917f21852fa
https://github.com/llvm/llvm-project/commit/65b123e287d1320170bb3317179bc917f21852fa
Author: eddyz87 <eddyz87 at gmail.com>
Date: 2024-03-14 (Thu, 14 Mar 2024)
Changed paths:
M clang/lib/Basic/Targets/BPF.cpp
M clang/test/Preprocessor/bpf-predefined-macros.c
M llvm/lib/Target/BPF/BPFCheckAndAdjustIR.cpp
M llvm/test/CodeGen/BPF/addr-space-globals.ll
M llvm/test/CodeGen/BPF/addr-space-globals2.ll
Log Message:
-----------
[BPF] rename 'arena' to 'address_space' (#85161)
There are a few places where `arena` name is used for pointers in
non-zero address space in BPF backend, rename these to use a more
generic `address_space`:
- macro `__BPF_FEATURE_ARENA_CAST` -> `__BPF_FEATURE_ADDR_SPACE_CAST
- name for arena global variables section `.arena.N` ->
`.addr_space.N`
To unsubscribe from these emails, change your notification settings at https://github.com/llvm/llvm-project/settings/notifications
More information about the All-commits
mailing list