[all-commits] [llvm/llvm-project] ec1138: [libc++] Rename __tuple to __tuple_dir to avoid fi...

Michał Górny via All-commits all-commits at lists.llvm.org
Wed Dec 21 10:21:19 PST 2022


  Branch: refs/heads/main
  Home:   https://github.com/llvm/llvm-project
  Commit: ec11388b3342a2b22eae22fd13ff4997b103d155
      https://github.com/llvm/llvm-project/commit/ec11388b3342a2b22eae22fd13ff4997b103d155
  Author: Michał Górny <mgorny at gentoo.org>
  Date:   2022-12-21 (Wed, 21 Dec 2022)

  Changed paths:
    M libcxx/include/CMakeLists.txt
    M libcxx/include/__functional/hash.h
    M libcxx/include/__fwd/get.h
    M libcxx/include/__memory/compressed_pair.h
    M libcxx/include/__ranges/subrange.h
    R libcxx/include/__tuple/apply_cv.h
    R libcxx/include/__tuple/make_tuple_types.h
    R libcxx/include/__tuple/sfinae_helpers.h
    R libcxx/include/__tuple/tuple_element.h
    R libcxx/include/__tuple/tuple_indices.h
    R libcxx/include/__tuple/tuple_like.h
    R libcxx/include/__tuple/tuple_size.h
    R libcxx/include/__tuple/tuple_types.h
    A libcxx/include/__tuple_dir/apply_cv.h
    A libcxx/include/__tuple_dir/make_tuple_types.h
    A libcxx/include/__tuple_dir/sfinae_helpers.h
    A libcxx/include/__tuple_dir/tuple_element.h
    A libcxx/include/__tuple_dir/tuple_indices.h
    A libcxx/include/__tuple_dir/tuple_like.h
    A libcxx/include/__tuple_dir/tuple_size.h
    A libcxx/include/__tuple_dir/tuple_types.h
    M libcxx/include/__utility/pair.h
    M libcxx/include/array
    M libcxx/include/libcxx.imp
    M libcxx/include/module.modulemap.in
    M libcxx/include/optional
    M libcxx/include/ranges
    M libcxx/include/utility
    M libcxx/test/libcxx/private_headers.verify.cpp
    M libcxx/utils/generate_iwyu_mapping.py

  Log Message:
  -----------
  [libc++] Rename __tuple to __tuple_dir to avoid file collision

Rename the `__tuple` directory in libc++ headers to `__tuple_dir`
to avoid file collision when installing.  Historically, `__tuple` has
been a file and it has been replaced by a directory
in 2d52c6bfae801b016dd3627b8c0e7c4a99405549.  Replacing a regular file
with a directory (or more importantly, the other way around when
downgrading) is not universally supported.  Since this is an internal
header, its actual name should not matter, so just rename it to avoid
problems.

Differential Revision: https://reviews.llvm.org/D139270




More information about the All-commits mailing list