[all-commits] [llvm/llvm-project] 80f2f1: [NFC] Rename Function::insertBasicBlockAt() to Fun...
vporpo via All-commits
all-commits at lists.llvm.org
Thu Dec 15 10:04:25 PST 2022
Branch: refs/heads/main
Home: https://github.com/llvm/llvm-project
Commit: 80f2f1eabc491cde39d543e4ebda93e2d2974d1f
https://github.com/llvm/llvm-project/commit/80f2f1eabc491cde39d543e4ebda93e2d2974d1f
Author: Vasileios Porpodas <vporpodas at google.com>
Date: 2022-12-15 (Thu, 15 Dec 2022)
Changed paths:
M clang/lib/CodeGen/CGStmt.cpp
M clang/lib/CodeGen/CodeGenFunction.cpp
M llvm/examples/Kaleidoscope/BuildingAJIT/Chapter1/toy.cpp
M llvm/examples/Kaleidoscope/BuildingAJIT/Chapter2/toy.cpp
M llvm/examples/Kaleidoscope/BuildingAJIT/Chapter3/toy.cpp
M llvm/examples/Kaleidoscope/BuildingAJIT/Chapter4/toy.cpp
M llvm/examples/Kaleidoscope/Chapter5/toy.cpp
M llvm/examples/Kaleidoscope/Chapter6/toy.cpp
M llvm/examples/Kaleidoscope/Chapter7/toy.cpp
M llvm/examples/Kaleidoscope/Chapter8/toy.cpp
M llvm/examples/Kaleidoscope/Chapter9/toy.cpp
M llvm/include/llvm/IR/Function.h
M llvm/lib/Frontend/OpenMP/OMPIRBuilder.cpp
M llvm/lib/IR/BasicBlock.cpp
M llvm/lib/IR/Core.cpp
M llvm/lib/Transforms/Utils/BreakCriticalEdges.cpp
M llvm/lib/Transforms/Utils/CloneFunction.cpp
M llvm/lib/Transforms/Utils/CodeExtractor.cpp
M llvm/lib/Transforms/Utils/LoopUnroll.cpp
M llvm/lib/Transforms/Utils/LoopUnrollAndJam.cpp
M llvm/lib/Transforms/Utils/LowerSwitch.cpp
M llvm/unittests/IR/FunctionTest.cpp
Log Message:
-----------
[NFC] Rename Function::insertBasicBlockAt() to Function::insert().
I think this is a better name because it is what STL uses.
Differential Revision: https://reviews.llvm.org/D140068
More information about the All-commits
mailing list