[all-commits] [llvm/llvm-project] dbc681: [VP][RISCV] Add vp.roundtozero and its RISC-V support
Yueh-Ting (eop) Chen via All-commits
all-commits at lists.llvm.org
Fri Oct 7 02:15:40 PDT 2022
Branch: refs/heads/main
Home: https://github.com/llvm/llvm-project
Commit: dbc681c98e14d495618ec42975e9f793d3a7a0b7
https://github.com/llvm/llvm-project/commit/dbc681c98e14d495618ec42975e9f793d3a7a0b7
Author: eopXD <yueh.ting.chen at gmail.com>
Date: 2022-10-07 (Fri, 07 Oct 2022)
Changed paths:
M llvm/docs/LangRef.rst
M llvm/include/llvm/IR/Intrinsics.td
M llvm/include/llvm/IR/VPIntrinsics.def
M llvm/lib/CodeGen/SelectionDAG/LegalizeVectorTypes.cpp
M llvm/lib/Target/RISCV/RISCVISelLowering.cpp
A llvm/test/CodeGen/RISCV/rvv/fixed-vectors-roundtozero-vp.ll
A llvm/test/CodeGen/RISCV/rvv/roundtozero-vp.ll
M llvm/unittests/IR/VPIntrinsicTest.cpp
Log Message:
-----------
[VP][RISCV] Add vp.roundtozero and its RISC-V support
The scalar instruction of this is `llvm.trunc`. However the naming of
ISD::VP_TRUNC is already taken by `trunc` of the LLVM IR. Naming this as
`vp.ftrunc` would likely cause confusion with `vp.fptrunc`. So adding
`vp.roundtozero` that will look similar to `vp.roundeven`.
Reviewed By: frasercrmck
Differential Revision: https://reviews.llvm.org/D135233
More information about the All-commits
mailing list