[all-commits] [llvm/llvm-project] 8187b8: [mlir] Rename arith.addi_carry to arith.addui_carry
Jakub Kuderski via All-commits
all-commits at lists.llvm.org
Wed Aug 24 07:43:57 PDT 2022
Branch: refs/heads/main
Home: https://github.com/llvm/llvm-project
Commit: 8187b8c42b07354995f89baeb5583ffb9f83f82e
https://github.com/llvm/llvm-project/commit/8187b8c42b07354995f89baeb5583ffb9f83f82e
Author: Jakub Kuderski <kubak at google.com>
Date: 2022-08-24 (Wed, 24 Aug 2022)
Changed paths:
M mlir/include/mlir/Dialect/Arithmetic/IR/ArithmeticOps.td
M mlir/lib/Conversion/ArithmeticToSPIRV/ArithmeticToSPIRV.cpp
M mlir/lib/Dialect/Arithmetic/IR/ArithmeticOps.cpp
M mlir/test/Conversion/ArithmeticToSPIRV/arithmetic-to-spirv.mlir
M mlir/test/Dialect/Arithmetic/canonicalize.mlir
M mlir/test/Dialect/Arithmetic/invalid.mlir
M mlir/test/Dialect/Arithmetic/ops.mlir
Log Message:
-----------
[mlir] Rename arith.addi_carry to arith.addui_carry
The intention is to have this op lowered to
`llvm.intr.uadd.with.overflow` or `spv.IAddCarry`. LLVM has a second
intrinsic for signed add-with-overflow, `llvm.intr.sadd.with.overflow`,
with different semantics. Therefore we should have 2 ops with `arith`,
and be explicit about signed/unsigned semantics.
Rename `arith.addi_carry` to `arith.addui_carry` before we introduce a
signed version of this op: `arith.addsi_carry`.
Reviewed By: antiagainst
Differential Revision: https://reviews.llvm.org/D132491
More information about the All-commits
mailing list