[all-commits] [llvm/llvm-project] f1cfa4: [flang][NFC] rename isAbsent to isStaticallyAbsent...

jeanPerier via All-commits all-commits at lists.llvm.org
Fri Apr 8 04:50:09 PDT 2022


  Branch: refs/heads/main
  Home:   https://github.com/llvm/llvm-project
  Commit: f1cfa461f28ed5bf77ca2e8f26cbf66fa09481a0
      https://github.com/llvm/llvm-project/commit/f1cfa461f28ed5bf77ca2e8f26cbf66fa09481a0
  Author: Jean Perier <jperier at nvidia.com>
  Date:   2022-04-08 (Fri, 08 Apr 2022)

  Changed paths:
    M flang/lib/Lower/IntrinsicCall.cpp

  Log Message:
  -----------
  [flang][NFC] rename isAbsent to isStaticallyAbsent in IntrinsicCall.cpp

isAbsent/isPresent helpers only give information about static presence
of intrinsic arguments. Many intrinsic arguments optionality is dynamic
(an absent dummy can legally be passed to these intrinsics). This
requires a different handling (like `handleDynamicOptional`).

Rename the helpers to avoid misleading coder/reader into thinking all
optionality cases are covered by them.

Differential Revision: https://reviews.llvm.org/D123378




More information about the All-commits mailing list