[all-commits] [llvm/llvm-project] 23d60c: [RISCV][NFC] Refine and refactor RISCVVEmitter and...
Zakk Chen via All-commits
all-commits at lists.llvm.org
Tue Mar 22 10:12:25 PDT 2022
Branch: refs/heads/main
Home: https://github.com/llvm/llvm-project
Commit: 23d60ce164db48cfaff84967e86dd052801bf73a
https://github.com/llvm/llvm-project/commit/23d60ce164db48cfaff84967e86dd052801bf73a
Author: Zakk Chen <zakk.chen at sifive.com>
Date: 2022-03-22 (Tue, 22 Mar 2022)
Changed paths:
M clang/include/clang/Basic/riscv_vector.td
M clang/utils/TableGen/RISCVVEmitter.cpp
M llvm/include/llvm/IR/IntrinsicsRISCV.td
Log Message:
-----------
[RISCV][NFC] Refine and refactor RISCVVEmitter and riscv_vector.td.
1. Rename nomask as unmasked to keep with the terminology in the spec.
2. Merge UnMaskpolicy and Maskedpolicy arguments into one in RVVBuiltin class.
3. Rename HasAutoDef as HasBuiltinAlias.
4. Move header definition code into one class.
Reviewed By: rogfer01
Differential Revision: https://reviews.llvm.org/D120870
More information about the All-commits
mailing list