[all-commits] [llvm/llvm-project] 229d57: Rename EHFrameSplitter to DWARFRecordSectionSplitter
Shubham Sandeep Rastogi via All-commits
all-commits at lists.llvm.org
Fri Mar 11 16:02:48 PST 2022
Branch: refs/heads/main
Home: https://github.com/llvm/llvm-project
Commit: 229d576b31f4071ab68c85ac4fabb78cfa502b04
https://github.com/llvm/llvm-project/commit/229d576b31f4071ab68c85ac4fabb78cfa502b04
Author: Shubham Sandeep Rastogi <srastogi22 at apple.com>
Date: 2022-03-11 (Fri, 11 Mar 2022)
Changed paths:
M llvm/lib/ExecutionEngine/JITLink/EHFrameSupport.cpp
M llvm/lib/ExecutionEngine/JITLink/EHFrameSupportImpl.h
M llvm/lib/ExecutionEngine/JITLink/ELF_x86_64.cpp
M llvm/lib/ExecutionEngine/JITLink/MachO_arm64.cpp
M llvm/lib/ExecutionEngine/JITLink/MachO_x86_64.cpp
M llvm/test/ExecutionEngine/JITLink/AArch64/MachO_arm64_ehframe.s
Log Message:
-----------
Rename EHFrameSplitter to DWARFRecordSectionSplitter
EHFrameSplitter does the exact same work to split up the eh_frame as it would need for any section that follows the DWARF record, therefore this patch just changes the name of it to DWARFRecordSectionSplitter to be more general.
Differential Revision: https://reviews.llvm.org/D121486
More information about the All-commits
mailing list