[all-commits] [llvm/llvm-project] da8bd9: [analyzer][NFC] Change return value of StoreManage...
Denys Petrov via All-commits
all-commits at lists.llvm.org
Fri Dec 17 03:04:04 PST 2021
Branch: refs/heads/main
Home: https://github.com/llvm/llvm-project
Commit: da8bd972a33ad642d6237b5b95b31a2a20f46a35
https://github.com/llvm/llvm-project/commit/da8bd972a33ad642d6237b5b95b31a2a20f46a35
Author: Denys Petrov <dpetrov at accesssoftek.com>
Date: 2021-12-17 (Fri, 17 Dec 2021)
Changed paths:
M clang/include/clang/StaticAnalyzer/Core/PathSensitive/Store.h
M clang/lib/StaticAnalyzer/Core/CallEvent.cpp
M clang/lib/StaticAnalyzer/Core/ExprEngineC.cpp
M clang/lib/StaticAnalyzer/Core/Store.cpp
Log Message:
-----------
[analyzer][NFC] Change return value of StoreManager::attemptDownCast function from SVal to Optional<SVal>
Summary: Refactor return value of `StoreManager::attemptDownCast` function by removing the last parameter `bool &Failed` and replace the return value `SVal` with `Optional<SVal>`. Make the function consistent with the family of `evalDerivedToBase` by renaming it to `evalBaseToDerived`. Aligned the code on the call side with these changes.
Differential Revision: https://reviews.llvm.org/
More information about the All-commits
mailing list