[Openmp-commits] [PATCH] D64080: [OPENMP]Make __kmpc_push_tripcount thread safe.
Hal Finkel via Phabricator via Openmp-commits
openmp-commits at lists.llvm.org
Fri Jul 5 18:45:34 PDT 2019
hfinkel added inline comments.
Comment at: libomptarget/src/device.h:101
+ // moved into the target task in libomp.
+ std::map<int32_t, uint64_t> loopTripCnt;
> hfinkel wrote:
> > While we're changing this, we should also update it to following our naming conventions:
> > loopTripCnt -> LoopTripCnt
> I thin the renaming better to put in another patch, but if you're ok with this, I'll rename it here
My thinking is: Because we need to change every line of code which references it anyway, changing the name along with changing the type makes sense. To me, I don't think it matters whether you split that into one patch or two. If you think it's cleaner to changing the name in a separate patch from changing the type, that's fine too.
CHANGES SINCE LAST ACTION
More information about the Openmp-commits