[llvm-dev] Can lit be upgraded to assume Python 2.7?

Sean Silva via llvm-dev llvm-dev at lists.llvm.org
Wed Feb 24 11:49:09 PST 2016

Great! I'll circle around to this at some point. Despite the "obvious"
nature of it I still am wary of underestimating the cruftiness of the
buildbots, so I'll probably do it some time at night when the bots are
mostly green so that I can easily see if any bots *are* broken by this.

-- Sean Silva

On Tue, Feb 23, 2016 at 6:55 PM, Chris Matthews <chris.matthews at apple.com>

> This sounds like a good idea to me!  I can’t think of any common platform
> where you can’t get 2.7.  Lets get rid of that legacy cruft!
> On Feb 23, 2016, at 1:32 PM, Eric Christopher <echristo at gmail.com> wrote:
> Seems reasonable to me. Chris?
> On Mon, Feb 22, 2016, 8:40 PM Sean Silva via llvm-dev <
> llvm-dev at lists.llvm.org> wrote:
>> In the root llvm/CMakeLists.txt we have:
>>   message(FATAL_ERROR "Python 2.7 or newer is required")
>> endif()
>> But lit seems to still be stuck in a Python 2.5 world. For example,
>> detectCPUs is redundant now that we have multiprocessing.cpu_count()
>> (multiprocessing requires >=2.6). And there are a bunch of other Python 2.5
>> workarounds floating around inside lit. I'm actually not sure if there are
>> 2.6 workarounds.
>> Anyway, does anybody know if somehow, despite the CMake check, lit is
>> still being run with Python <2.7 on any bots or anywhere? If not, I'd like
>> to make a couple cleanup patches.
>> -- Sean Silva
>> _______________________________________________
>> LLVM Developers mailing list
>> llvm-dev at lists.llvm.org
>> http://lists.llvm.org/cgi-bin/mailman/listinfo/llvm-dev
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-dev/attachments/20160224/a83dc101/attachment.html>

More information about the llvm-dev mailing list