[llvm-dev] Can lit be upgraded to assume Python 2.7?

Chris Matthews via llvm-dev llvm-dev at lists.llvm.org
Tue Feb 23 18:55:42 PST 2016

This sounds like a good idea to me!  I can’t think of any common platform where you can’t get 2.7.  Lets get rid of that legacy cruft!

> On Feb 23, 2016, at 1:32 PM, Eric Christopher <echristo at gmail.com> wrote:
> Seems reasonable to me. Chris?
> On Mon, Feb 22, 2016, 8:40 PM Sean Silva via llvm-dev <llvm-dev at lists.llvm.org <mailto:llvm-dev at lists.llvm.org>> wrote:
> In the root llvm/CMakeLists.txt we have:
>   message(FATAL_ERROR "Python 2.7 or newer is required")
> endif()
> But lit seems to still be stuck in a Python 2.5 world. For example, detectCPUs is redundant now that we have multiprocessing.cpu_count() (multiprocessing requires >=2.6). And there are a bunch of other Python 2.5 workarounds floating around inside lit. I'm actually not sure if there are 2.6 workarounds.
> Anyway, does anybody know if somehow, despite the CMake check, lit is still being run with Python <2.7 on any bots or anywhere? If not, I'd like to make a couple cleanup patches.
> -- Sean Silva
> _______________________________________________
> LLVM Developers mailing list
> llvm-dev at lists.llvm.org <mailto:llvm-dev at lists.llvm.org>
> http://lists.llvm.org/cgi-bin/mailman/listinfo/llvm-dev <http://lists.llvm.org/cgi-bin/mailman/listinfo/llvm-dev>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-dev/attachments/20160223/591bc743/attachment.html>

More information about the llvm-dev mailing list