[LLVMdev] APFloat::convertToDouble asserts
dalej at apple.com
Fri Jul 9 13:05:10 PDT 2010
On Jul 9, 2010, at 12:59 PMPDT, Jochen Wilhelmy wrote:
>>> I wonder why APFloat::convertToDouble asserts if it is not an
>>> APFloat::IEEEdouble while the name "convertToDouble" suggests that
>>> converts when it is not a double.
>> The conversion is to (host) double, as the name implies. Among
>> APFloat types, that is only implemented for APFloat::IEEEdouble.
> yes, it's to host double ("convert this APFloat to double"),
> therefore I hoped that it works for any APFloat type (otherwise I
> would suggest a name such as getIfIEEEdouble() ).
> Is there a reason against it or would it be accepted if it would
> work for any type?
I'd rather not. The functionality you want is there, feed another
APFloat type through APFloat::convert first.
Using host FP is not something that should be encouraged; the main
point of APFloat is so people don't have to do that. Why do you want
More information about the llvm-dev