[LLVMdev] compiling release_22 witout bison installed gives broken build

Chris Lattner sabre at nondot.org
Wed Jan 23 10:34:54 PST 2008

On Wed, 23 Jan 2008, Tomas Lindquist Olsen wrote:
> Hi. I had a strange issue today. basically llvm-as refused to do
> anything, borking out on the simplest of module:
> ; ModuleID = 'test'
> @_nothing_works_here = constant i32 42
> $ llvm-as test.ll
> llvm-as: test.ll:1,0: test.ll:1: error: parse error, expecting
> `GLOBAL' or `CONSTANT' while reading token: '@_nothing_works_here'

It is possible that the llvmAsmParser.y.cvs file is out of date.  Can you 
try regenerating the .cvs file, then uninstalling bison, then retrying the 


> It turns out that I forgot to install bison before compiling llvm, but
> configure did not complain about this. After I installed bison and
> tried over, the build worked perfectly.
> So I'm guessing this is a bug in the configure scripts somewhere.
> I use linux on x86 with gcc 4.2.2 and as said llvm from svn
> llvm/branches/release_22
> Baldrick helped me realize what was wrong (by building the same
> checkout and confirming it worked) and encouraged me to write about it
> here.
> - Tomas
> _______________________________________________
> LLVM Developers mailing list
> LLVMdev at cs.uiuc.edu         http://llvm.cs.uiuc.edu
> http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev



More information about the llvm-dev mailing list