[LLVMdev] Trouble with sample project's autoconf

Reid Spencer rspencer at reidspencer.com
Fri Feb 23 11:28:39 PST 2007

Hello Scott,

On Wed, 2007-02-21 at 18:57 -0500, me22 wrote:
> I'm trying to follow docs/Projects.html to use llvm in a project of my own.
> If I just copy the sample directory, running configure in the new one
> works fine:
> ~/programming/llvm-1.9/projects $ cp -a sample/ zhe
> ~/programming/llvm-1.9/projects $ cd zhe/
> ~/programming/llvm-1.9/projects/zhe $ ./configure
> configure: creating ./config.status
> config.status: creating Makefile.common
> config.status: executing setup commands
> config.status: executing Makefile commands
> config.status: executing lib/Makefile commands
> config.status: executing lib/sample/Makefile commands
> config.status: executing tools/Makefile commands
> config.status: executing tools/sample/Makefile commands
> However, if I run the AutoRegen.sh script (after modifying it to
> accept autoconf 2.61, which I think is fine as gentoo slots it the
> same as the 2.5[0-9] versions), the configure no longer works:
> ~/programming/llvm-1.9/projects/zhe $ cd autoconf/
> ~/programming/llvm-1.9/projects/zhe/autoconf $ ./AutoRegen.sh
> Regenerating aclocal.m4 with aclocal
> /usr/share/aclocal/sdlmm.m4:12: warning: underquoted definition of AM_PATH_SDLMM
> /usr/share/aclocal/sdlmm.m4:12:   run info '(automake)Extending aclocal'
> /usr/share/aclocal/sdlmm.m4:12:   or see
> http://sources.redhat.com/automake/automake.html#Extending-aclocal

This one is because you're using 2.61. This kind of thing i why we
*strongly* recommend people to use only the exact version of autoconf,
libtool and automake that LLVM uses. There's obviously a difference in
your aclocal that isn't handling the AM_PATH_SDLMM macro correctly. 

> Regenerating configure with autoconf 2.5x
> ~/programming/llvm-1.9/projects/zhe/autoconf $ cd ..
> ~/programming/llvm-1.9/projects/zhe $ ./configure
> configure: error: cannot find install-sh or install.sh in
> ../../../autoconf "."/../../../autoconf

Assuming that your /programming/llvm-1.9 directory contains llvm 1.9, it
should have found it in /programming/llvm-1.9/autoconf/install-sh. Check
to make sure that that directory and file are there. If it is there,
then its some kind of bug.

> I've tried this with both the 1.9 release and a fresh CVS checkout,
> with the same results.  What am I missing?

Nothing. :)

> Confused,
> Scott McMurray
> _______________________________________________
> LLVM Developers mailing list
> LLVMdev at cs.uiuc.edu         http://llvm.cs.uiuc.edu
> http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev

More information about the llvm-dev mailing list