[LLVMdev] Trouble with sample project's autoconf

me22 me22.ca at gmail.com
Wed Feb 21 15:57:53 PST 2007

I'm trying to follow docs/Projects.html to use llvm in a project of my own.

If I just copy the sample directory, running configure in the new one
works fine:
~/programming/llvm-1.9/projects $ cp -a sample/ zhe
~/programming/llvm-1.9/projects $ cd zhe/
~/programming/llvm-1.9/projects/zhe $ ./configure
configure: creating ./config.status
config.status: creating Makefile.common
config.status: executing setup commands
config.status: executing Makefile commands
config.status: executing lib/Makefile commands
config.status: executing lib/sample/Makefile commands
config.status: executing tools/Makefile commands
config.status: executing tools/sample/Makefile commands

However, if I run the AutoRegen.sh script (after modifying it to
accept autoconf 2.61, which I think is fine as gentoo slots it the
same as the 2.5[0-9] versions), the configure no longer works:
~/programming/llvm-1.9/projects/zhe $ cd autoconf/
~/programming/llvm-1.9/projects/zhe/autoconf $ ./AutoRegen.sh
Regenerating aclocal.m4 with aclocal
/usr/share/aclocal/sdlmm.m4:12: warning: underquoted definition of AM_PATH_SDLMM
/usr/share/aclocal/sdlmm.m4:12:   run info '(automake)Extending aclocal'
/usr/share/aclocal/sdlmm.m4:12:   or see
Regenerating configure with autoconf 2.5x
~/programming/llvm-1.9/projects/zhe/autoconf $ cd ..
~/programming/llvm-1.9/projects/zhe $ ./configure
configure: error: cannot find install-sh or install.sh in
../../../autoconf "."/../../../autoconf

I've tried this with both the 1.9 release and a fresh CVS checkout,
with the same results.  What am I missing?

Scott McMurray

More information about the llvm-dev mailing list