[PATCH] D149021: [TTI][ASAN] Introduce TTI::getInterestingMemoryOperand.

Yeting Kuo via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Apr 24 09:17:15 PDT 2023


fakepaper56 added inline comments.


================
Comment at: llvm/include/llvm/Analysis/TargetTransformInfo.h:889
+  // Return InterestingMemoryOperand of Intrinsic \p II.
+  InterestingMemoryOperand getInterestingMemoryOperand(IntrinsicInst *II) const;
+
----------------
kparzysz wrote:
> The term "interesting" is meaningless in this context.  We should use more descriptive names in files that are shared among multiple users.
I am bad at naming. Do you think MemoryRefInfo is a good new name?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D149021/new/

https://reviews.llvm.org/D149021



More information about the llvm-commits mailing list