[PATCH] D77768: [mlir] Refactor ClassID into a more robust TypeID class.

Mehdi AMINI via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Apr 8 21:02:58 PDT 2020


mehdi_amini added inline comments.


================
Comment at: mlir/lib/Dialect/Affine/Transforms/AffineLoopInvariantCodeMotion.cpp:44-45
 ///       uses.
-struct LoopInvariantCodeMotion
-    : public AffineLoopInvariantCodeMotionBase<LoopInvariantCodeMotion> {
+struct AffineLoopInvariantCodeMotion
+    : public AffineLoopInvariantCodeMotionBase<AffineLoopInvariantCodeMotion> {
   void runOnFunction() override;
----------------
rriddle wrote:
> stephenneuendorffer wrote:
> > rename seems unrelated?
> It's actually not, as the name of this pass matches the one for the other LICM. 
That has me concerned with the mechanism here if it can't differentiate.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D77768/new/

https://reviews.llvm.org/D77768





More information about the llvm-commits mailing list