[PATCH] D77768: [mlir] Refactor ClassID into a more robust TypeID class.

River Riddle via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Apr 8 20:36:50 PDT 2020


rriddle added a comment.

In D77768#1970938 <https://reviews.llvm.org/D77768#1970938>, @stephenneuendorffer wrote:

> Seems like a big change.  I don't know if it's worthwhile breaking it down first (like const ClassID * -> TypeID, as a separate change).   Might be hard to get the const correctness right, I guess.


Yeah, happy to split it. I mainly wanted one patch to make it easier for me to transfer to my windows machine.



================
Comment at: mlir/lib/Dialect/Affine/Transforms/AffineLoopInvariantCodeMotion.cpp:44-45
 ///       uses.
-struct LoopInvariantCodeMotion
-    : public AffineLoopInvariantCodeMotionBase<LoopInvariantCodeMotion> {
+struct AffineLoopInvariantCodeMotion
+    : public AffineLoopInvariantCodeMotionBase<AffineLoopInvariantCodeMotion> {
   void runOnFunction() override;
----------------
stephenneuendorffer wrote:
> rename seems unrelated?
It's actually not, as the name of this pass matches the one for the other LICM. 


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D77768/new/

https://reviews.llvm.org/D77768





More information about the llvm-commits mailing list