[PATCH] D68192: Fix PR40710: Outlined Function has token parameter but isn't an intrinsic

Saleem Abdulrasool via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Sep 30 08:31:55 PDT 2019


compnerd accepted this revision.
compnerd added inline comments.
This revision is now accepted and ready to land.


================
Comment at: llvm/lib/Transforms/IPO/HotColdSplitting.cpp:344
+
+  if (!CE.validInputs(Inputs))
+    return nullptr;
----------------
For some reason it feels like an odd name to me.  What do you think of something like `validateDataDependencies` or something along those lines?  I think the fact that input is slightly fuzzy is why it just feels odd, but, I can understand where that comes from too.


================
Comment at: llvm/test/Transforms/HotColdSplit/token-arg.ll:1
+; RUN: opt -S %s -hotcoldsplit -o /dev/null
+define void @zot() personality i8* bitcast (i32 (...)* @bar to i8*) {
----------------
Might not be a bad idea to ensure that the transformation is idempotent - that is to have checks on the output IR


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D68192/new/

https://reviews.llvm.org/D68192





More information about the llvm-commits mailing list